Crypto.com Main App and Exchange web login page unavailable

Incident Report for Crypto.com

Resolved

This incident has beer resolved.
Posted Apr 02, 2026 - 11:44 HKT

Investigating

We are aware of users experiencing connection issues with the Crypto.com Main App and Exchange login page.

Our team is working on urgently resolving this. Thank you for your patience.
Posted Apr 02, 2026 - 10:30 HKT
This incident affected: Crypto.com App/Web (Main Page).